Pumapeople: Hatch Trim - Pumapeople

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Hatch Trim Rate Topic: -----

#1 User is offline   Pisney 

  • Group: Members
  • Posts: 5
  • Joined: 29-February 08

Posted 08 August 2019 - 01:40 PM

Hi,

I made the mistake of asking the local Halfords Autocentre to check why the high level brake light wasn't working, after I'd cleaned all the sprung connectors. They managed to break the mounting clip of the small end trim piece on the hatch accessing the bulbs, and it still didn't work.

Thanks to this site, I've fixed the light, the connector on the driver side strut had broken. But the trim is now held in place with duck tape. Anyone know of a supplier that can still provide the part, or a breaker with a Puma available?

This particular Autocentre also broke the manifold when replacing the cambelt and water pump a couple of years ago, and ended up just welding it back together, I don't think I'll use them again.

Thanks
Paul

#2 User is offline   happy-kat 

  • Group: Admin
  • Posts: 21781
  • Joined: 10-February 03
  • Location:Sarnian abroad

Posted 08 August 2019 - 07:25 PM

Hi, that was unfortunate but glad your overall light issue you have fixed.
Could try Ian at Pumabits (Ian G on here) for your broken piece.
searching is fruitful | I'm a sponge not a mechanic | The Wiki is cool, please do check there if stuck with a Puma problem whilst waiting for a reply | For the Puma fan this read 'The Inside Story Book' is very nice to own link coming soon

#3 User is offline   Pisney 

  • Group: Members
  • Posts: 5
  • Joined: 29-February 08

Posted 14 August 2019 - 08:56 AM

Thanks

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic