Pumapeople: Puma 1.7 Vct "the Green Bullet" - Pumapeople

Jump to content

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Puma 1.7 Vct "the Green Bullet" Rate Topic: -----

#21 User is offline   SandStorm 

  • Group: Members
  • Posts: 30
  • Joined: 17-August 16

Posted 07 April 2017 - 10:39 AM

So, this time for some reason, my key fob (IrDA) stopped working.
Then, discovered the car had alarm when it would activate when i opened the door or put the engine running.
Something did messed up. So, i disconnected car battery and removed the keys batteries too.
connected everything again, was unable to program the key. Then later, maybe after an hour or more, was able to program it, and solved my issues. All works again. But now I know the car does have an alarm, because i didnt knew. :lol:

Well, today I did some care to my Bullet, so... Decided to buy better quality leather for the steering wheel, and this time did it all around.

Posted Image

Posted Image

I like the results. :)

#22 User is offline   happy-kat 

  • Group: Admin
  • Posts: 21690
  • Joined: 10-February 03
  • Location:Sarnian abroad

Posted 07 April 2017 - 06:18 PM

Is the leather glued or stitched on?
searching is fruitful | I'm a sponge not a mechanic | The Wiki is cool, please do check there if stuck with a Puma problem whilst waiting for a reply | For the Puma fan this read 'The Inside Story Book' is very nice to own link coming soon

#23 User is offline   SandStorm 

  • Group: Members
  • Posts: 30
  • Joined: 17-August 16

Posted 08 April 2017 - 10:38 PM

 happy-kat, on 07 April 2017 - 06:18 PM, said:

Is the leather glued or stitched on?


I stitched it :) took like 40 minutes

#24 User is offline   SandStorm 

  • Group: Members
  • Posts: 30
  • Joined: 17-August 16

Posted 20 September 2017 - 04:56 PM

Been a while since my last post.
So, in the meantime I had my rear shoes replaced.

Even If nowadays I notice the brake very stiff if the car sits for hours. Some vacuum leak somewhere.
And also sometimes vibrates a bit when braking, I suspect the problem is the rear drum.

Anyways, did some interior mods with this:

Posted Image

Posted Image

Posted Image


Also replaced my air vents because they were broken and fitted these:

Posted Image

Replaced my homemade buttons surround fix with a good looking piece too.
Went to MOT:

Posted Image

And passed with only advisories for oil leaks.

#25 User is offline   SandStorm 

  • Group: Members
  • Posts: 30
  • Joined: 17-August 16

Posted 18 October 2017 - 02:15 PM

Been having the P0443 error since I bought this car, but today I sorted it out. Simply replaced that evap valve. 96FB-9C915

Posted Image

Posted Image

Posted Image

#26 User is offline   happy-kat 

  • Group: Admin
  • Posts: 21690
  • Joined: 10-February 03
  • Location:Sarnian abroad

Posted 19 October 2017 - 08:22 PM

Such a small part too, good fix.
searching is fruitful | I'm a sponge not a mechanic | The Wiki is cool, please do check there if stuck with a Puma problem whilst waiting for a reply | For the Puma fan this read 'The Inside Story Book' is very nice to own link coming soon

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic