Pumapeople: Temp Gauge And Mpg - Pumapeople

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Temp Gauge And Mpg

#1 User is offline   edesonc 

  • Group: Members
  • Posts: 4
  • Joined: 06-February 17

Posted 15 February 2017 - 08:23 AM

Hi all

my puma was running too cold on the analogue dial (R Reg) so i had the thermostat changed. Since this has been done the dial sits a little higher on the N or O of normal on the gauge.

my question is, is this normal? i read on the WIKI that some say it should sit bolt up right in the middle and some say it should sit on the N? which is correct?

if its supposed to be in the middle, what else can i do to see whats wrong after changing the thermostat?

Also, to try and monitor this, if there is an issue, i guess my MPG will be out. what miles to a full tank do you get? on an average week mostly country roads i get 300/350 on a tank......

thanks all

#2 User is offline   SandStorm 

  • Group: Members
  • Posts: 36
  • Joined: 17-August 16

Posted 18 October 2017 - 05:24 PM

Maybe you replaced it with a thermo that opens too early? that can be the issue.
But honestly, in my eyes if it sits in the N.O. with UK colder weather and calm driving, it's good. It's on the scale of normal running temperature
Have you monitored it on highway runs? Both at 75mph runs and 100mph runs?

I give you the example with my ford Orion. Precisely same issue as yours. Changed thermo, changed everything I could from the cooling system. And is just like that. Also, I suppose the digital dash cars sit higher than analog ones, but i can be wrong.

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic