Pumapeople: Frp Running Rough - Pumapeople

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Frp Running Rough

#1 User is offline   FRP 067 

  • Group: Members
  • Posts: 132
  • Joined: 26-April 06
  • Location:Gravesend ~ Kent

Posted 22 March 2018 - 03:25 PM

Hi my FRP has developed a problem & my garage is going on a big old fishing trip as they donít really know what the issue is. Basically itís bogging down, and feels like itís too low a gear. Itís hesitating and spluttering and loosing some power. It feels like it would die at any time. Iíve had it since 2002 so I know the car well. Personally I donít think itís the idel control as Iíve had that & it hunts and stalls. But that is what they plan to do next. They have already swapped the air mass thingy. It only happened the other day and I got it straight in.
Faults
P0172 - System too rich bank 1P1132 - Lack of HO2S11 switch - sends indicates richPO133 - o2 sensor circuit slow response bank 1 sensor 1
If that helps...
Iím thinking Hugo sensor or whatever itís called lamba thing.
Any help appreciated to reduce my bill.
Thanks Darryl.



#2 User is online   happy-kat 

  • Group: Admin
  • Posts: 21720
  • Joined: 10-February 03
  • Location:Sarnian abroad

Posted 22 March 2018 - 03:58 PM

Remove the hego, how does it run now. If better then buy new hego.
Running rich and then lean creates a horrible lumpy drive. You exhaust pipe is likely got deep soot you could draw in.
searching is fruitful | I'm a sponge not a mechanic | The Wiki is cool, please do check there if stuck with a Puma problem whilst waiting for a reply | For the Puma fan this read 'The Inside Story Book' is very nice to own link coming soon

#3 User is offline   FRP 067 

  • Group: Members
  • Posts: 132
  • Joined: 26-April 06
  • Location:Gravesend ~ Kent

Posted 23 March 2018 - 05:39 PM

happy-kat said:

1521734334[/url]' post='940008']
Remove the hego, how does it run now. If better then buy new hego.
Running rich and then lean creates a horrible lumpy drive. You exhaust pipe is likely got deep soot you could draw in.



Thanks & Iíll pass it on to my garage.
Another quick one, bushes wise are ours all the same as standard Pumas? I tried calling Powerflex but their sales staff were pretty useless and didnít have a clue.

#4 User is offline   nottadam 

  • Group: Members
  • Posts: 174
  • Joined: 12-April 13

Posted 23 March 2018 - 06:05 PM

Hi

All bushes are standard Puma EXCEPT the rear ones in the front wishbones, they are uprated but still physically same size.

Paul



FRP#008, 2001 1.6 Med Steel Blue, Fiesta 1.5 TDCi Zetec S

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic