Pumapeople: Heater Control Valve/airlock? - Pumapeople

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Heater Control Valve/airlock?

#1 User is offline   Felix001 

  • Group: Members
  • Posts: 4
  • Joined: 13-August 15

Posted 13 August 2015 - 09:41 AM

Hi everyone, just bought a new puma, T reg 1.7. I owned a Puma for 8 years or so a few years back and missed it so much and saw this one for sale and couldn't resist!

There's a few bits need doing to it and thought I'd start with the easy job of replacing the broken HCV. It worked fine once I'd finished (ran for around 5-10mins, aircon working fine too). Drove it this morning and had the same problem. I've tried bleeding the system but it doesn't seem to be working (no bubbles in radiator, no loss of coolant, no need to top up). The only thing I notice is the coolant level in rad actually fills up a bit and then back down again. Any ideas please?

The part used is an OE part from Europarts (the only type they had in), I've had parts from them before with no trouble.

#2 User is offline   happy-kat 

  • Group: Admin
  • Posts: 21766
  • Joined: 10-February 03
  • Location:Sarnian abroad

Posted 13 August 2015 - 04:09 PM

Hi
There are a few heating articles in the wiki which might help whilst waiting for a reply.
searching is fruitful | I'm a sponge not a mechanic | The Wiki is cool, please do check there if stuck with a Puma problem whilst waiting for a reply | For the Puma fan this read 'The Inside Story Book' is very nice to own link coming soon

#3 User is offline   nottadam 

  • Group: Members
  • Posts: 174
  • Joined: 12-April 13

Posted 13 August 2015 - 05:58 PM

You probably don't want to hear this, but you need to buy the proper Ford HCV. So many people have reported the same problems when fitting cheaper HCVs.
Paul
FRP#008, 2001 1.6 Med Steel Blue, Fiesta 1.5 TDCi Zetec S

#4 User is offline   Felix001 

  • Group: Members
  • Posts: 4
  • Joined: 13-August 15

Posted 13 August 2015 - 07:38 PM

View Postnottadam, on 13 August 2015 - 05:58 PM, said:

You probably don't want to hear this, but you need to buy the proper Ford HCV. So many people have reported the same problems when fitting cheaper HCVs.
Paul


:( I've picked up a used one today from the breakers yard, genuine ford part, with the newer engineer /part number and will try it tomorrow. To be honest, I hope thats all it is, its just strange that it worked straight after replacing it and then after being sat overnight, same problem again which is what made me think it might be an airlock and the new part was good.

Thanks for the replies so far :)

#5 User is offline   Felix001 

  • Group: Members
  • Posts: 4
  • Joined: 13-August 15

Posted 14 August 2015 - 07:30 PM

Hi guys, so I bought a brand new HCV from the local ford dealer today and fitted it, still no luck and only hot air blowing. Is there anything else it could be? Could the connector to the HCV be damaged? I've removed and checked the panel below the radio and the dials are turning so I don't think its that. Any other ideas would be great :)

#6 User is offline   happy-kat 

  • Group: Admin
  • Posts: 21766
  • Joined: 10-February 03
  • Location:Sarnian abroad

Posted 14 August 2015 - 08:40 PM

Have a read in the Wiki.
http://www.pumapeopl...le=Puma_Heating
searching is fruitful | I'm a sponge not a mechanic | The Wiki is cool, please do check there if stuck with a Puma problem whilst waiting for a reply | For the Puma fan this read 'The Inside Story Book' is very nice to own link coming soon

#7 User is offline   Felix001 

  • Group: Members
  • Posts: 4
  • Joined: 13-August 15

Posted 14 August 2015 - 09:14 PM

Hi, I've read every post I could find on this problem! I think I may have now sorted it. After fitting the new genuine ford HCV this afternoon and still having just hot air blowing, I decided to switch the heater control panel with one I had lying around from an old fiesta and good news - it worked! It looks like the cheap part from europarts leaked coolant into the HCV electrics and blew the panel so fingers crossed it will still be working tomorrow. Lesson learned though, next time I will buy a genuine ford HCV and pay the extra! Thanks for your help and suggestions, next job - fix the passenger door card I've just noticed is half hanging off :)

#8 User is offline   eldoodarino 

  • Group: Moderators
  • Posts: 6257
  • Joined: 12-March 03
  • Location:Nottingham

Posted 15 August 2015 - 11:28 AM

Buy the right clips.. ;)

Finis 1044806 (8 per door card)
Wizards Of Nos 60hp progressive delivery.... yeah baby yeah :-o
Denso Iridium Plugs
Helix Clutch
Mobil 1


Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic